본문으로 바로가기

[ 문제 ]

그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오.

 

단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다.

정점 번호는 1번부터 N번까지이다.

 

[ 입력 ]

  • 첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다.
  • 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다.
  • 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다.
  • 입력으로 주어지는 간선은 양방향이다.

 

[ 출력 ]

  • 첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다.
  • V부터 방문된 점을 순서대로 출력하면 된다.

 

[ 예제 입력 ]

4 5 1

1 2

1 3

1 4

2 4

3 4

 

[ 예제 출력 ]

1 2 4 3

1 2 3 4

 


 

import java.util.*;
import java.io.*;

public class Main {
	
	private static void bfs(int N, boolean[][] adjMatrix, int V) {
		Queue<Integer> queue = new LinkedList<>();
		boolean[] visited = new boolean[N+1];
		
		queue.offer(V);
		visited[V] = true;
		
		while (!queue.isEmpty()) {
			int current = queue.poll();
			System.out.print(current + " ");
			
			for (int i = 1; i < N+1; i++) {
				if (!visited[i] && adjMatrix[current][i]) {
					queue.offer(i);
					visited[i] = true;
				}
			}
		}
	}
	
	
	private static void dfs(int N, boolean[][] adjMatrix, int current, boolean[] visited) {
		visited[current] = true;
		System.out.print(current + " ");
		
		for (int i = 1; i < N+1; i++) {
			if (!visited[i] && adjMatrix[current][i]) {
				visited[i] = true;
				dfs(N, adjMatrix, i, visited);
			}
		}
	}
	

	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		StringTokenizer st = new StringTokenizer(br.readLine());
		
		int N = Integer.parseInt(st.nextToken()); // 정점의 개수
		int M = Integer.parseInt(st.nextToken()); // 간선의 개수
		int V = Integer.parseInt(st.nextToken()); // 탐색을 시작할 정점의 번호

		boolean[][] adjMatrix = new boolean[N+1][N+1];
		
		for (int i = 0; i < M; i++) {
			st = new StringTokenizer(br.readLine());
			int from = Integer.parseInt(st.nextToken());
			int to = Integer.parseInt(st.nextToken());
			
			adjMatrix[from][to] = adjMatrix[to][from] = true;
		}
		
		boolean[] visited = new boolean[N+1];
		dfs(N, adjMatrix, V, visited);
		System.out.println();
		bfs(N, adjMatrix, V);
	}
}